How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:
[ i i i i o o o o i o i i o o i o ]
where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.
Input
The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.
Output
For each input pair, your program should produce a sorted list of valid sequences ofi ando which produce the target word from the source word. Each list should be delimited by
[ ]and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Process
A stack is a data storage and retrieval structure permitting two operations:
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:
i i o i o o | is valid, but |
i i o | is not (it's too short), neither is |
i i o o o i | (there's an illegal pop of an empty stack) |
Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequencei i o i o o produce the anagram OOF. So also would the sequencei i i o o o. You are to write a program to input pairs of words and output all the valid sequences ofi ando which will produce the second member of each pair from the first.
Sample Input
madam adamm bahama bahama long short eric rice
Sample Output
[ i i i i o o o i o o i i i i o o o o i o i i o i o i o i o o i i o i o i o o i o ] [ i o i i i o o i i o o o i o i i i o o o i o i o i o i o i o i i i o o o i o i o i o i o i o i o ] [ ] [ i i o i o i o o ]
Source: Zhejiang University Local Contest 2001
先记录一个错误的代码:
#include<stdio.h>
#include<string.h>
char A[100];char B[100];
int n;char stack[100];int ans[100];char last[100];
int cnt;int key;
void dfs(int x,int num)
{
if(num>n)return;
if(x==n*2+1&&num==n)
{
if(strcmp(last,B)==0)
{
int a;
for(a=1;a<=2*n;a++)
if(ans[a]==0)printf("o ");
else printf("i ");
printf("\n");
}
return;
}
ans[x]=1;stack[++key]=A[num];dfs(x+1,num+1);key--;
if(key>=0){ans[x]=0;last[x-num-1]=stack[key--];dfs(x+1,num);key++;}
return;
}
int main()
{
while(scanf("%s%s",A,B)!=EOF)
{
printf("[\n");
for(n=0;A[n]!='\0';n++);
cnt=0;key=-1;
if(B[n]=='\0')dfs(1,0);
printf("]\n");
memset(A,0,sizeof(A));
memset(B,0,sizeof(B));
memset(stack,0,sizeof(stack));
memset(ans,0,sizeof(ans));
memset(last,0,sizeof(last));
}
return 0;
}
AC代码:
#include<stdio.h>
#include<string.h>
char A[100];char B[100];
int n;char stack[100];int ans[100];char last[100];
int cnt;int key;
void dfs(int x,int num)
{
if(num>n)return;
if(x==n*2+1&&num==n)
{
if(strcmp(last,B)==0)
{
int a;
for(a=1;a<=2*n;a++)
if(ans[a]==0)printf("o ");
else printf("i ");
printf("\n");
}
return;
}
ans[x]=1;int t=stack[key+1];stack[++key]=A[num];dfs(x+1,num+1);stack[key--]=t;
if(key>=0){ans[x]=0;last[x-num-1]=stack[key--];dfs(x+1,num);key++;}
return;
}
int main()
{
while(scanf("%s%s",A,B)!=EOF)
{
printf("[\n");
for(n=0;A[n]!='\0';n++);
cnt=0;key=-1;
if(B[n]=='\0')dfs(1,0);
printf("]\n");
memset(A,0,sizeof(A));
memset(B,0,sizeof(B));
memset(stack,0,sizeof(stack));
memset(ans,0,sizeof(ans));
memset(last,0,sizeof(last));
}
return 0;
}
谨慎递归中的栈!因为递归过程中,栈会前后摆动,如果只对栈的指针进行移动,回溯回去后,可能原来的地方值已经改变了,所以在栈变动过程中,要有一个恢复值的过程!