Radar Installation (线段覆盖)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 94767 Accepted: 21097

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


不就是一个线段覆盖模型嘛。把每个岛映射到坐标轴上就是一条线段。找出做多有多少条互相不相交(端点衔接也叫相交)。不相交的线段组里每个必须得放一个雷达嘛。那么其他的线段任意一个总与组里一个相交,雷达调整好位置即可。而根据我们贪心的选取方法。一条线段未被选入,那么他一定跟前一个相交。这样我们把雷达放在选出组里每条线段的末尾,就可以实现全覆盖了~



#include<cstdio>  
#include<cmath>
#include<algorithm>
using namespace std;
const int MAXN=1003;
int X[MAXN],Y[MAXN];
struct Line{
    double l,r;
}line[MAXN];
int n,d;
int cmp(const Line &a,const Line &b){
    return a.r<b.r;
}
int solve(){
    if(d<=0||n<=0)return -1;   //注意极端特殊的情况
    for(int i=0;i<n;i++){
        double dis=d*d*1.0-Y[i]*Y[i]*1.0;
        if(dis<0)return -1;   //不满足条件
        line[i].l=X[i]-sqrt(dis);
        line[i].r=X[i]+sqrt(dis);
    }
    sort(line,line+n,cmp);
    int t=0,ans=1;   //第一个雷达站肯定要放置
    for(int i=1;i<n;i++){
        if(line[i].l>line[t].r){
            t=i;
            ans++;
        }
    }
    return ans;
}
int main()
{
    int t=0;
    while(scanf("%d%d",&n,&d)){
        if(n==0&&d==0)break;
        for(int i=0;i<n;i++)
            scanf("%d%d",&X[i],&Y[i]);
        int res=solve();
        printf("Case %d: %d\n",++t,res);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值