Maximal Clique

最大团:团内的点是相互连通的,并且无法找出另一个节点和团内节点是联通的。

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

#include<bits/stdc++.h>
using namespace std;

int main() {
	int mp[300][300];
	int n,m;
	cin>>n>>m;
	for(int i=0; i<m; i++) {
		int a,b;
		scanf("%d%d",&a,&b);
		mp[a][b]=mp[b][a]=1;
	}
	int t;
	cin>>t;
	for(int i=0; i<t; i++) {
		int d;
		int v[300];
		map<int ,int >hash;
		hash.clear();
		scanf("%d",&d);
		for(int j=0; j<d; j++) {
			scanf("%d",&v[j]);
			hash[v[j]]=1;
		}
		int flag=0;
		for(int j=0; j<d; j++) {
			for(int k=0; k<d; k++) {
				if(j==k)continue;
				if(mp[v[j]][v[k]]==0) {
				
					cout<<"Not a Clique"<<endl;
					flag=1;
					break;
				}
			}
			if(flag==1)break;
		}
		if(flag==1) {

			continue;
		}


		int ismax=0,flag2=0;
		for(int j=1; j<=n; j++) {

			ismax=0;
			if(hash[j]==0) {
				for(int k=0; k<d; k++) {
					if(mp[v[k]][j]==0) {
						ismax=1;
						break;
					}

				}
				if(ismax==0) {
					cout<<"Not Maximal"<<endl;
					flag2=1;
					break;

				}
			}

		}
		if(flag2==1) {

			continue;
		}

		cout<<"Yes"<<endl;
	}
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值