C - Lowest Common Multiple Plus

     求n个数的最小公倍数。 
Input
    输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
Output
    为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
Sample Input

    2 4 6
    3 2 5 7

Sample Output

    12
    70
#include<stdio.h>
#include<string.h>
int main()
{
	int n,left,right;
	char num[99];
	scanf("%d", &n);
	while (n--)
	{
		int count = 0;
		int sum = 0;
		scanf("%s", &num);
		right = strlen(num)-1;
		left = 0;
		while (left <= right)
		{
			if (num[left] == num[right])
				count++;
			right--;
			left++;
		}
		if (strlen(num) % 2 != 0)
		{
		if (count == strlen(num) / 2 + 1)
			printf("yes\n");
		else
			printf("no\n");

		}
		else
		{
			if(count==strlen(num)/2)
				printf("yes\n");
			else
				printf("no\n");
		}
	}



	return 0;
}

按照题目的意思做即可

这里我运用了类似之前做二分查找时所用的方法

这里附上答案的两种做法

#include <stdio.h>
#include <string.h>

int main(void)
{
	int n, len, i;
	char s[1024];
	
	scanf("%d%*c", &n);
	
	while (n--)
	{
		gets(s);
		len = strlen(s);
		for (i = 0; i <= len / 2; i++)
		{
			if (s[i] != s[len - 1 - i])
				break;
		}
		puts(s[i] != s[len - 1 - i] ? "no" : "yes");
	}
	
	return 0;
}
#include <stdio.h>
#include <string.h>

int main(void)
{
    int n;
    char s[1024];
    char t[1024];

    scanf("%d%*c", &n);
    
    while (n--)
    {
        gets(s);
        strcpy(t, s);
        strrev(s);
        puts(strcmp(t, s) ? "no" : "yes");
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZZWWWFFF_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值