poj 2081 Recaman's Sequence

Recaman's Sequence
Time Limit: 3000MS Memory Limit: 60000K
Total Submissions: 22529 Accepted: 9678

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m. 
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

Source



#include<stdio.h>
#include<string.h>
int  res[500005];
bool vis[3000005];	//res[i]的结果会很大,要开大一点vis[] 
int main(){
	int n;
	memset(vis,true,sizeof(vis));
	res[0]=0;
	for(int i=1;i<=500000;i++){
		int x=res[i-1]-i;
		if(x>0&&vis[x]){ //判断当前值是否是正数并且保证不在res中 
			res[i]=res[i-1]-i;
			vis[x]=false; 
		}
		else {
			res[i]=res[i-1]+i;
			vis[res[i]]=false;
		}
	}
	while(scanf("%d",&n)){
		if(n<0) break;
		printf("%d\n",res[n]);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值