HDU(1098):Ignatius's puzzle

题目:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11874    Accepted Submission(s): 8365

Problem Description

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

Input

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output

The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input

11

100

9999

Sample Output

22

no

43

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1098

题解:

我考虑到的问题有:

1、题意:方程f(x)=5*x^13+13*x^5+k*a*x;输入任意一个数k,是否存在一个数a,对任意x都能使得f(x)能被65整除;

2、怎样保证任意x都能使得f(x)能被65整除;

解法:(数学归纳法)

当x=1时f(x)=18+k*a,又因为f(x)能被65整出,所以设n为整数,则f(x)=n*65;

即:18+k*a=n*65;

对于给定范围的a只需要验证,是否存在一个a使得(18+k*a)%65==0

代码:

#include<cstdio>
using namespace std;
int main()
{
 int n,i,k;
 while(~scanf("%d",&k))
 {
     for(i=1;i<=65;i++)
     {
         if((18+i*k)%65==0)
           {
              printf("%d\n",i);
              break;
           }
     }
     if(i>=66)
        printf("no\n");
 }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值