HDU1098 Ignatius's puzzle(数学归纳法求解)(数论)

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input

11
100
9999

Sample Output

22
no
43

题目大意:输入k,然后求对于任意的x,使f(x)能被65整除时,输出此时最小的a。

想法如下:
数学归纳法证明:

f(x)=5*x^13+13*x^5+k*a*x

第一步:f(0)=0;成立:

第二步:假设f(x)能被65整除,则有5*x^13+13*x^5+k*a*x能被65整出;

第三步:则f(x+1)=5*(x+1)^13+13*(x+1)^5+k*a*(x+1);

根据二项式定理分析题目:

f(x+1)=5*(c(13,0)+c(13,1)x+c(13,2)*x^2+…….+c(13,13)*x^13)+13(c(5,0)+c(5,1)x+……+c(5,5)*x^5)+k*a(x+1)

=f(x)+5*(c(13,0)+c(13,1)x+c(13,2)*x^2+…….+c(13,12)*x^12)+13(c(5,0)+c(5,1)*x+……+c(5,4)*x^4)+k*a;

=f(x)+5+5*c(13,1)*x+5*c(13,2)*x^2+……+5*c(13,12)*x^12+13+13*c(5,1)*x+…..+k*a;
此时会发现5(n+1)^13+13(x+1)^5一定能被%65==0.

用f(x+1)-f(x),会发现,只有18+ka不能确定是否能%65==0;又因(18+ka)%65=(18%65+(k%65)*(a%65))%65,由此可以确定0

#include <stdio.h>
int main()
{
    int k,i;
    while(~scanf("%d",&k))
    {

        for(i=1;i<=65;i++)
        {
            if((18+k*i)%65==0)
            {
                printf("%d\n",i);
                break;
            }
        }
        if(i==66)printf("no\n");
    }

    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值