HDOJ 1098 Ignatius's puzzle

Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input
11
100
9999

Sample Output
22
no
43

题目大意:方程f(x)=5*x^13+13*x^5+k*a*x;输入任意一个数k,是否存在一个数a,对任意x都能使得f(x)能被65整除。
现假设存在这个数a ,因为对于任意x方程都成立
所以,当x=1时f(x)=18+ka
又因为f(x)能被65整出,故设n为整数
可得,f(x)=n*65;
即:18+ka=n*65;
因为n为整数,若要方程成立
则问题转化为,
对于给定范围的a只需要验证,
是否存在一个a使得(18+k*a)%65==0
所以容易解得
注意,这里有童鞋不理解为什么a只需到65即可
因为,当a==66时
也就相当于已经找了一个周期了,所以再找下去也找不到适当的a了

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int k= sc.nextInt();
            boolean flag=false;
            for(int a=0;a<=65;a++){
                if((18+k*a)%65==0){
                    System.out.println(a);
                    flag = true;
                    break;
                }
            }

            if(!flag){
                System.out.println("no");
            }

        }

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值