E - 5 C++

题目:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路:很简单的bfs,而且是一维的。考虑牛移动的三种情况即可。

代码:

#include<iostream>
#include<queue>
using namespace std;
const int INF=100000000;
long long int fun(int i,long long int ss)
{
    long long int s;
    if(i==0)s=ss-1;
    if(i==1)s=ss+1;
    if(i==2)s=ss*2;
    return s;
}
void bfs(long long int a,long long int b)
{
    queue<long long int>q;
    q.push(a);
    int i;
    long long int d[100005];
    for(i=0;i<100005;i++){d[i]=INF;}
    d[a]=0;
    while(q.size())
    {
        long long int s=q.front();q.pop();
        if(s==b){cout<<d[b]<<endl;return;}
        long long int ss=s;
        for(i=0;i<3;i++)
        {
            s=fun(i,ss);
            if(s>=0&&s<=100000&&d[s]==INF)
                {
                    q.push(s);
                    d[s]=d[ss]+1;
                }
        }
    }
}
int main()
{
    long long int n,k;
    while(cin>>n>>k)
    {
        bfs(n,k);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值