hdu3047-带权并查集

题目:

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3974    Accepted Submission(s): 1519


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output
For every case:
Output R, represents the number of incorrect request.
 

Sample Input
  
  
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output
2


题意:给你两个人a,b和一个距离x要求b坐在a的右边距离x远的位置,给出一系列的安排座位的指令,问你有几个指令是不合法的(即与之前的已有的安排有冲突的).

思路:用一个dis数组存该点与根结点的距离,那么在合并两个人时有两种情况,1:他们已经在同一集合,那么只要判断他们现有的dis之差是否等于x。2:他们不在同一集合,那么更新dis数组的值,并将b所在集合放入a中。

代码:

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
const int maxn=111111;
using namespace std;

int f[maxn],dis[maxn];
int n,m;
int a,b,x;
int ans;

int Get_f(int v)
{
    if(f[v]==v)
        return v;
    int fa=f[v];
    f[v]=Get_f(f[v]);
    dis[v]=dis[v]+dis[fa];
    return f[v];
}

int Merge(int v,int u)
{
    int vv=Get_f(v);
    int uu=Get_f(u);
    if(vv==uu)
    {
        if(dis[u]-dis[v]!=x)
            ans++;
    }
    else
    {
        f[uu]=vv;
        dis[uu]=dis[v]+x-dis[u];
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=0;
        for(int i=1;i<=n;i++)
        {
            f[i]=i;
            dis[i]=0;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&x);
            Merge(a,b);
            /*for(int j=1;j<=10;j++)
            {
                 printf("f%d:%d   dis%d : %d\n",j,f[j],j,dis[j]);
            }
            printf(" ans:%d\n",ans);*/
        }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值