Zjnu Stadium HDU - 3047(带权并查集)

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
Sample Output
2

Hint
Hint:
(PS: the 5th and 10th requests are incorrect)
一个体育馆内有300个座位,编号为B的人要在编号为A的人的顺时针方向x个位置。问给出的座位有多少个是错误的。
今晚做的这几个带权并查集的题目都是这样的,这个题目也不例外,但是这里注意是300个座位围成一个圈。所以需要取模300。其实不取模直接算也是可以的。但是取模之后要注意,在做差的时候有可能是负数,所以需要加上300。
代码如下:

#include<bits/stdc++.h>
#define ll long long
#define mod 300
using namespace std;

const int maxx=5e4+100;
int f[maxx],dis[maxx];
int n,m;

inline int getf(int u)
{
	int x;
	if(u!=f[u])
	{
		x=getf(f[u]);
		dis[u]=(dis[u]+dis[f[u]])%mod;
		f[u]=x;
	}
	return f[u];
}
inline int merge(int u,int v,int val)
{
	int t1=getf(u);
	int t2=getf(v);
	if(t1==t2)
	{
		swap(u,v);
		if((dis[u]+val)%mod!=dis[v]) return 1;
		else return 0;
	}
	else
	{
		f[t1]=t2;
		dis[t1]=(dis[v]-dis[u]+val+mod)%mod;//这一块要自己好好理解,容易写错了。。
		return 0;
	}
}
int main()
{
	int x,y,v;
	while(~scanf("%d%d",&n,&m))
	{
		int ans=0;
		for(int i=0;i<=n;i++) f[i]=i,dis[i]=0;
		while(m--)
		{
			scanf("%d%d%d",&x,&y,&v);//swap(x,y);
			if(merge(x,y,v)) ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值