HDU 6180 Schedule(贪心)

作者:CSDN博主 最菜的acmer

链接:点击打开链接

原题

Schedule

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 153428/153428 K (Java/Others)



Problem Description

There are N schedules, the i-th schedule has start time si and end time ei (1 <= i <= N). There are some machines. Each two overlapping schedules cannot be performed in the same machine. For each machine the working time is defined as the difference between timeend and timestart , where time_{end} is time to turn off the machine and timestart is time to turn on the machine. We assume that the machine cannot be turned off between the timestart and the timeend.
Print the minimum number K of the machines for performing all schedules, and when only uses K machines, print the minimum sum of all working times.


Input

The first line contains an integer T (1 <= T <= 100), the number of test cases. Each case begins with a line containing one integer N (0 < N <= 100000). Each of the next N lines contains two integers si and ei (0<=si<ei<=1e9).


Output

For each test case, print the minimum possible number of machines and the minimum sum of all working times.


Sample Input

1
3
1 3
4 6
2 5


Sample Output

2 8


题意

给出任务的开始时间和结束时间,一台机器同一时间只能做一个任务,且只能开关机一次,问最少需要多少台机器和对应的最少的工作时间之和。


涉及知识及算法


按任务开始时间从小到大排序后,从头开始加入set容器:如果任务开始时间大于等于set里的最近的结束时间,就插入 ,否则就重新开一台机器即可。


代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<vector>
#include<algorithm>
#include<string>
#include <set>
using namespace std;
typedef long long LL;
const int MAX_N = 1e5+5;

struct node
{
    int s,e;
};
node a[MAX_N];

bool cmp(node a,node b)
{
    return a.s<b.s;
}

multiset<int>st;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        st.clear();
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a[i].s,&a[i].e);
        }
        sort(a,a+n,cmp);
        LL ans=0;
        for(int i=0;i<n;i++)
        {
            multiset<int>::iterator it=st.upper_bound(a[i].s);
            //如果没找到
            if(it==st.begin())
            {
                //开一台机器
                ans+=a[i].e-a[i].s;
                st.insert(a[i].e);
            }
            //如果找到
            else
            {
                //加入
                it--;
                ans+=a[i].e-*it;
                st.erase(it);
                st.insert(a[i].e);
            }
        }
        printf("%d %lld\n",st.size(),ans);
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值