Sticks Problem

Problem Description
Xuanxuan has n sticks of different length. One day, she puts all her sticks in a line, represented by S1, S2, S3, ...Sn. After measuring the length of each stick Sk (1 <= k <= n), she finds that for some sticks Si and Sj (1<= i < j <= n), each stick placed between Si and Sj is longer than Si but shorter than Sj.

Now given the length of S1, S2, S3, …Sn, you are required to find the maximum value j - i.
 

Input
The input contains multiple test cases. Each case contains two lines.< br>Line 1: a single integer n (n <= 50000), indicating the number of sticks.< br>Line 2: n different positive integers (not larger than 100000), indicating the length of each stick in order.
 

Output
Output the maximum value j - i in a single line. If there is no such i and j, just output -1.
 

Sample Input
  
  
4 5 4 3 6 4 6 5 4 3
 

Sample Output
  
  
1 -1

题目大概:

是看一下给出的数列中是否存在单调递增的子序列,然后求子序列的长度-1。没有则是-1。

思路:

这个题用单调队列直接维护一个单调队列,然后求维护中最长的一个队列是多少就行了,但是tle,原来还要用别的方法,线段树后者其他,这个都没学,看到暴力破解可以,就用了暴力。

代码:

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;

int a[55000];
int n;
int main()
{
    while(cin>>n)
    {
        int sun=0;
        int mid;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }

         int i=0;
        while(i<n-1)
      {

          int sum=a[i];
           mid=i;

          int j;
          for(j=i+1;j<n;j++)
          {
              if(a[j]<=a[i])
              {
                  
                  i=mid+1;
                  break;
              }
              else if(a[j]<=sum)
              {
                  if(j==n-1)i=mid+1;
                  continue;
              }
              else
              {
                  if(j-i>sun)sun=j-i;
                  sum=a[j];
                  mid=j;
              }
              if(j==n-1)i=mid+1;

          }

      }

      if(sun==0)printf("%d\n",-1);
      else printf("%d\n",sun);

    }

    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值