POJ 2452 Sticks Problem

Sticks Problem
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 10282 Accepted: 2723

Description

Xuanxuan has n sticks of different length. One day, she puts all her sticks in a line, represented by S1, S2, S3, ...Sn. After measuring the length of each stick Sk (1 <= k <= n), she finds that for some sticks Si and Sj (1<= i < j <= n), each stick placed between Si and Sj is longer than Si but shorter than Sj. 

Now given the length of S1, S2, S3, …Sn, you are required to find the maximum value j - i.

Input

The input contains multiple test cases. Each case contains two lines. 
Line 1: a single integer n (n <= 50000), indicating the number of sticks. 
Line 2: n different positive integers (not larger than 100000), indicating the length of each stick in order.

Output

Output the maximum value j - i in a single line. If there is no such i and j, just output -1.

Sample Input

4
5 4 3 6
4
6 5 4 3

Sample Output

1
-1

Source

POJ Monthly,static


题意:找到一个最长的区间,这个区间中间每个数字都要小于末尾的数,并且要大于区间开头的数,输出符合要求的最大区间长度
思路:先记录每一位数后面连续大于这个数的长度,然后再这个长度里找最大的数,这样可求得最大的区间

#include <cstdio>
using namespace std;

int a[50001], dis[50001];
int main()
{
    int n, flag, i, j, maxn, ans;
    while (scanf("%d", &n)!= EOF){
        ans = 0;
        for (i = 1; i <= n; i++){
            scanf("%d", &a[i]);
            dis[i] = 1;
        }
        dis[n + 1] = -1;
        for (i = n; i >= 0; i--){
            while (a[i] < a[i + dis[i]])
                dis[i] += dis[i + dis[i]];
        }
        for (i = 1; i <= n; i += flag + 1){
            maxn = flag = -1;
            for (j = 0; j < dis[i]; j++){
                if (a[i + j] > maxn){
                    maxn = a[i + j];
                    flag = j;
                }
            }
            if (flag > ans)
                ans = flag;
        }
        if(ans)
            printf("%d\n", ans);
        else
            printf("-1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值