Sticks Problem (单调队列)

   Sticks Problem

Time Limit : 12000/6000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 31   Accepted Submission(s) : 6
Problem Description
Xuanxuan has n sticks of different length. One day, she puts all her sticks in a line, represented by S1, S2, S3, ...Sn. After measuring the length of each stick Sk (1 <= k <= n), she finds that for some sticks Si and Sj (1<= i < j <= n), each stick placed between Si and Sj is longer than Si but shorter than Sj.

Now given the length of S1, S2, S3, …Sn, you are required to find the maximum value j - i.
 

Input
The input contains multiple test cases. Each case contains two lines.<br>Line 1: a single integer n (n <= 50000), indicating the number of sticks.<br>Line 2: n different positive integers (not larger than 100000), indicating the length of each stick in order.
 

Output
Output the maximum value j - i in a single line. If there is no such i and j, just output -1.
 

Sample Input
  
  
4 5 4 3 6 4 6 5 4 3
 

Sample Output
  
  
1 -1
 

Source
PKU
 

题意:找到一个最长的区间,这个区间中间每个数字都要小于最后一个数并且要大于最开始(即区间开头)的数,输出符合要求的最大区间长度。

思路:先记录每一位数后面连续大于这个数的长度,然后再这个长度里找最大的数,这样可求得最大的区间。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <iomanip>
#define maxn 50005
#define mod 1000000007
#define INF 0x3f3f3f3f
#define exp 1e-6
#define pi acos(-1.0)
using namespace std;
int a[maxn],dis[maxn];  //a用来存储数据,dis用来表示某一个数后大于连续大于这个数的长度
int n;
int main()
{
    ios::sync_with_stdio(false);
    int i;
    int ans,flag,maxx;
    while(cin>>n)
    {
        ans=0;
        for(i=1;i<=n;i++){cin>>a[i];dis[i]=1;}   //输入数据吗,初始化为1
        dis[n+1]=-1;    //别忘了这个,因为后面寻找最大的的时候可能超过。
        for(i=n;i>=0;i--)
        {
            while(a[i]<a[i+dis[i]])dis[i]+=dis[i+dis[i]];  //找出所有符合要求的长度
        }
        for(i=1;i<=n;i+=flag+1)  //下一次要在最大的那个数的下一个位置
        {
            maxx=flag=-1;
            for(int j=0;j<dis[i];j++)
            {
                if(a[i+j]>maxx){maxx=a[i+j],flag=j;}  //在区间内找长度。
            }
            if(ans<flag)ans=flag;   //找到最大的值
        }
        if(ans)cout<<ans<<endl;
        else cout<<"-1"<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值