Apple Tree (树形dp+背包)

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input
There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.
Output
For each test case, output the maximal numbers of apples Wshxzt can eat at a line.
Sample Input
2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3
Sample Output
11
2

题目大概:

在一个树中每个结点都有价值,一个人可以从任意结点出发,在m步内能获得的总价值是都少。

思路:

又是背包,不过和原来的不一样。

这个花费的是步数,拿到的还是价值。

dp[x][j][1]是从x结点出发,回到x结点,花费了j步,获得的价值。

dp[x][j][0]是从x结点出发,不回到x结点,花费了j步,获得价值。

状态转移方程。

当不回来

dp[x][j][0]=max(dp[x][j][0],dp[x][j-k][1]+dp[son][k-1][0]);   

//先走其他儿子,再回到x结点,然后再去这个儿子son,在这个结点和儿子son间花费一步,所以k-1。j-k是另外一个儿子花费的步数。

dp[x][j][0]=max(dp[x][j][0],dp[x][j-k][0]+dp[son][k-2][1]);
//先走这个儿子son,再回到这个结点,然后再走其他结点,花费两步。

回来

dp[x][j][1]=max(dp[x][j][1],dp[x][j-k][1]+dp[son][k-2][1]);

//走son,然后回来。
  

代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
#define ll long long
const int ma=105;
ll n,m;
ll dp[ma][222][2];
ll nao[ma];
ll head[ma];
ll ans,sum;
ll minshu;
struct shu
{
    int v;
    int next;
}tr[205];

void add(ll q,ll w)
{
    tr[ans].v=w;
    tr[ans].next=head[q];
    head[q]=ans++;

}


void dfs(int x,int pa)
{
   for(int i=0;i<=m;i++)dp[x][i][0]=dp[x][i][1]=nao[x];
    for(int i=head[x];i!=-1;i=tr[i].next)
    {
        int son=tr[i].v;
        if(pa!=son)
        {
            dfs(son,x);
            for(int j=m;j>=0;j--)
            {
                for(int k=0;k<=j;k++)
                {
                    if(k>=1)dp[x][j][0]=max(dp[x][j][0],dp[x][j-k][1]+dp[son][k-1][0]);
                    if(k>=2)
                    {dp[x][j][1]=max(dp[x][j][1],dp[x][j-k][1]+dp[son][k-2][1]);
                    dp[x][j][0]=max(dp[x][j][0],dp[x][j-k][0]+dp[son][k-2][1]);
                    }

                }
            }
        }
    }

}

int main()
{


   while(~scanf("%I64d%I64d",&n,&m))
   {
       if(n==0&&m==0)break;
       memset(dp,0,sizeof(dp));
       memset(head,-1,sizeof(head));
       memset(nao,0,sizeof(nao));
       ans=0;
       for(int i=1;i<=n;i++)
       {
           scanf("%I64d",&nao[i]);

       }
       for(int i=1;i<=n-1;i++)
       {
           int q,w;
            scanf("%d%d",&q,&w);
            add(q,w);
            add(w,q);

       }

       dfs(1,-1);

       printf("%I64d\n",max(dp[1][m][0],dp[1][m][1]));

   }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值