poj 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 74223 Accepted: 23398

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

提示

题意:
农夫约翰想要立刻抓住一只牛,他们分别位于一条直线上的两个点,农夫行走的规则如下:
1.在当前位置(x)后退一格(x-1),或前进一格(x+1)。
2.在当前位置(x)跳到另一个位置(2*x)。
问最少要几步才能抓到牛,假设牛不动。
思路:
BFS入门题

示例程序

Source Code

Problem: 3278		Code Length: 980B
Memory: 1528K		Time: 32MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
struct
{
    int pos,step;
}q[400000];
int bfs(int n,int k)
{
    int v[100001],f=0,top=0;
    memset(v,0,sizeof(v));
    q[top].pos=n;
    q[top].step=0;
    v[n]=1;
    top++;
    while(f<top)
    {
        if(q[f].pos==k)
        {
            return q[f].step;
        }
        if(q[f].pos+1<=100000&&v[q[f].pos+1]==0)
        {
            q[top].pos=q[f].pos+1;
            q[top].step=q[f].step+1;
            v[q[top].pos]=1;
            top++;
        }
        if(q[f].pos-1>=0&&v[q[f].pos-1]==0)
        {
            q[top].pos=q[f].pos-1;
            q[top].step=q[f].step+1;
            v[q[top].pos]=1;
            top++;
        }
        if(q[f].pos*2<=100000&&v[q[f].pos*2]==0)
        {
            q[top].pos=q[f].pos*2;
            q[top].step=q[f].step+1;
            v[q[top].pos]=1;
            top++;
        }
        f++;
    }
}
int main()
{
    int n,k;
    scanf("%d %d",&n,&k);
    printf("%d",bfs(n,k));
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值