poj 3252 Round Numbers

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12086 Accepted: 4570

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source

提示

题意:

给出两个数让你计算出两个数之间有多少个数为“round number”。(闭区间)

round number定义为一个数的二进制表示方法,0的个数大于等于1的个数。例如:12(1100),4(100)。

思路:


(图片来自http://www.cnblogs.com/lyy289065406/archive/2011/07/31/2122758.html,里面的解析更清楚)。

首先计算出二进制长度小于finish的个数。

for(i=1;l>i;i++)
{
    for(i1=i/2+1;i>=i1;i1++)
    {
        num=num+c[i][i1];
    }
}
 

l为去掉最高位的长度。(最高位只能是1,所以没有加进去)

 

i/2+1表示至少要有几个0的个数,要保证0的个数一直大于等于1的个数。

之后进行长度与finish一样的个数,从高位到低位,下面以一个例子来讲述:

for(i=l;i>=1;i--)
{
    if(q[i-1]==1)
    {
        for(i1=l/2-a;i>i1;i1++)
        {
            num=num+c[i-1][i1];
        }
    }
    else
    {
        a++;
    }
}
 
 
 

12的二进制是1100,现在的状态为1XXX,l为3。(X表示未遍历的位置)

当X为0时,我们就降一位,因为我们进行排列组合时才不会超出范围,并且需要计数。

X为1时,我们把它看做是0,之后对后面的位数进行排列组合,这样无论怎么组合也不会超出范围,l/2-a为至少要有几个0的个数,a呢就是之前遍历时0出现的次数,前面出现过0,后面进行排列组合0需要的个数也会变少,这些步骤完成以后再接着向下遍历。

10XX→i=3,num=num+c[2][1]+c[2][2](1010 1001 1000)

110X→i=2,num=num,a++

1100→i=1,num=num,a++

说了那么多希望会有所帮助。

示例程序

Source Code

Problem: 3252		Code Length: 820B
Memory: 392K		Time: 16MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int c[31][31];
int f(int x)
{
    int i,i1,q[31],l,a=0,num=0,t;
    for(i=0;x!=0;i++)
    {
        q[i]=x%2;
        x=x/2;
    }
    l=i-1;
    for(i=1;l>i;i++)
    {
        for(i1=i/2+1;i>=i1;i1++)
        {
            num=num+c[i][i1];
        }
    }
    for(i=l;i>=1;i--)
    {
        if(q[i-1]==1)
        {
            for(i1=l/2-a;i>i1;i1++)
            {
                num=num+c[i-1][i1];
            }
        }
        else
        {
            a++;
        }
    }
    return num;
}
int main()
{
    int n,m,i,i1;
    memset(c,0,sizeof(c));
    for(i=0;30>=i;i++)
    {
        c[i][0]=1;
        for(i1=1;i>=i1;i1++)
        {
            c[i][i1]=c[i-1][i1-1]+c[i-1][i1];
        }
    }
    scanf("%d %d",&n,&m);
    printf("%d",f(m+1)-f(n));							//这个算法不包括自己所以m要+1
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值