poj 3096 Surprising Strings

Surprising Strings
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6723 Accepted: 4386

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source

提示

题意:

给出一个字符串,比如:ZGBG可以拆成ZG,GB,BG,或者ZB,GG,或者ZG,如果其中的一组有重复的情况输出“XXX is NOT surprising.”,否则输出“XXX is surprising.”。

思路:

暴力,map都行。

示例程序

暴力:

Source Code

Problem: 3096		Code Length: 1043B
Memory: 388K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int main()
{
    int i,len,i1,i2,top,bug;
    char ch[80],ch1[80][2];
    scanf("%s",ch);
    while(ch[0]!='*')
    {
        bug=0;
        len=strlen(ch);
        for(i=1;len>=i;i++)
        {
            top=0;
            for(i1=0;len-i>i1;i1++)
            {
                for(i2=0;top>i2;i2++)
                {
                    if(ch1[i2][0]==ch[i1]&&ch1[i2][1]==ch[i1+i])
                    {
                        break;
                    }
                }
                if(top!=i2)
                {
                    bug=1;
                    break;
                }
                ch1[top][0]=ch[i1];
                ch1[top][1]=ch[i1+i];
                top++;
            }
            if(bug==1)
            {
                break;
            }
        }
        if(bug==0)
        {
            printf("%s is surprising.\n",ch);
        }
        else
        {
            printf("%s is NOT surprising.\n",ch);
        }
        scanf("%s",ch);
    }
    return 0;
}
map:

Source Code

Problem: 3096		Code Length: 1052B
Memory: 724K		Time: 32MS
Language: G++		Result: Accepted
#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;
int main()
{
    int bug,i,i1,len;
    char ch[80],ch1[3];
    while(scanf("%s",ch)!=EOF&&ch[0]!='*')
    {
        bug=0;
        len=strlen(ch);
        if(len<3)
        {
            printf("%s is surprising.\n",ch);
            continue;
        }
        for(i=1;len>=i;i++)
        {
            map<string,int>a;
            for(i1=0;len-i>i1;i1++)
            {
                ch1[0]=ch[i1];
                ch1[1]=ch[i1+i];
                ch1[2]='\0';
                if(a[ch1]==0)
                {
                    a[ch1]=1;
                }
                else
                {
                    bug=1;
                    break;
                }
            }
            if(bug==1)
            {
                break;
            }
        }
        if(bug==0)
        {
            printf("%s is surprising.\n",ch);
        }
        else
        {
            printf("%s is NOT surprising.\n",ch);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值