Stars
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. You are to write a program that will count the amounts of the stars of each level on a given map. Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input 5 1 1 5 1 7 1 3 3 5 5 Sample Output 1 2 1 1 0 Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source |
提示
解析来源于书。
题意:
有若干个星星,给出每个星星在二维平面上的坐标(输入按y递增顺序给出,y相同时按x递增顺序给出)。定义每个星星的级别为横纵坐标均不超过自己的星星个数(不包括自身),问级别为0~N-1的星星分别有多少个。
思路:
按照题目输入。当前星星与后面的星星没关系。所以只要把x之前的横坐标加起来就行了。此题用树状数组再适合不过了。不过要注意树状数组从下标1开始算起,所以,题目中当x=0时,要执行x++,相当于所有坐标向右移一位,但是没有改变坐标间的相对顺序。
其中的x&-x不理解的看这,treap也可做。
示例程序
Source Code
Problem: 2352 Code Length: 571B
Memory: 572K Time: 407MS
Language: GCC Result: Accepted
#include <stdio.h>
#include <string.h>
int level[32001],c[32001];
int lowbit(int x)
{
return x&(-x);
}
int sum(int x)
{
int s=0;
while(x>0)
{
s=s+c[x];
x=x-lowbit(x);
}
return s;
}
void update(int pos)
{
while(pos<=32001)
{
c[pos]++;
pos=pos+lowbit(pos);
}
}
int main()
{
int n,i,x,y;
scanf("%d",&n);
memset(c,0,sizeof(c));
for(i=1;n>=i;i++)
{
scanf("%d %d",&x,&y);
level[sum(x+1)]++;
update(x+1);
}
for(i=0;n>i;i++)
{
printf("%d\n",level[i]);
}
return 0;
}