hdu 1541 Stars 入门 树状数组

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9977    Accepted Submission(s): 4001


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1166  1394  3450  1542  1255 
 


本菜刚学树状数组,在网上搜到的简单入门题,然而没做过一道题的我也是不会,看了看他们的解析,恩,可以解。

他是先按y递增的顺序在按x递增的顺序给的测试实例,让我们求出来每个点左下角点的个数,先不管y,输入一个x,他之后的每个星星level都要+1,

接下来再来考虑y增大的时候,这时候正好level等于小于等于他x的所有之和,接下来就可以用树状数组了,

开了个num数组,用来记录level

ac代码

#include <stdio.h> 
#include <cmath>
#include <cstring>
#include <queue>
#include <algorithm>
#define ll long long 
using namespace std;

const int maxn=32000+5;
int n;
int x,y;
int tree[maxn];
int num[maxn];

void add(int k,int nu){
	while(k <= maxn){
		tree[k] += nu;
		k += k&-k;
	}
}

int Sum(int end){
	int sum=0;
	while(end > 0){
		sum+=tree[end];
		end-=end&-end;
	}
	
	return sum;
}

int main()
{	
	while(~scanf("%d",&n)){
		memset(tree,0,sizeof(tree));
		memset(num,0,sizeof(num));
		for(int i=0;i<n;i++){
			scanf("%d%d",&x,&y);
			num[Sum(x+1)]++;
			add(x+1,1);
		}
		for(int i=0;i<n;i++){
			printf("%d\n",num[i]);
		}
	}
	
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值