poj1925 Spiderman

Spiderman
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7015 Accepted: 1404

Description

Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web. 

From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards. 

You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

Input

The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

Output

For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.

Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4

Sample Output

3
-1

蜘蛛侠大意:

给你n个建筑物的坐标和高度,当前的情景认为是建筑物在一条直线上的。

然后蜘蛛侠每次可以把绳子拴在建筑物顶端进行摆动,当到达关于挂绳子的建筑物对称的位置的时候,表示完成了一次摆动。

因此不难发现,蜘蛛侠完成摆动的高度必定是一样的,都和它的公寓的建筑物的高度一样。

现在问你蜘蛛侠从1到n至少要摆动多少次。

思路:

一开始想着用贪心就能做来着,但是发现这样不行,因为如果你是尽量的选择靠右的建筑物,因为摆动半径不能超过建筑物高度,所以你也不知道向右多少个建筑物才是可行的。对于每个建筑物都是这样,这样如果贪心的话很明显就是错误的了。因为能摆动的建筑物受到高度和距离你人的距离两个因素影响,所以当前最优不代表最终最优包含这个。

因此我们就要记录多种状态了,我们用dp[i]表示在数轴i处所需要的最少摆动次数。

然后枚举每一个建筑,对于每一个建筑:

1.枚举此建筑可能开始的摆动点坐标,如果之前蜘蛛侠可以摆动到这个点,那么更新摆动后的点的坐标的dp值。

注意:

不要超出左边界和右边界

一层层更新过去,(就像bfs)最终得到的答案便是最小的摆动次数啦。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int MAXN=5000+10;
const int inf=0x3f3f3f3f;
int n;
int x[MAXN],h[MAXN];
int dp[1000005];
int main()
{
    int i,j;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;++i)scanf("%d%d",&x[i],&h[i]);
        memset(dp,inf,sizeof(dp));
        dp[x[0]]=0;//最初(能到达)的点
        for(i=1;i<n;++i)
        {
            int dis=sqrt(h[i]*1.0*h[i]-(h[i]-h[0])*1.0*(h[i]-h[0]));
            for(j=1;j<=dis;++j)
            {
                int xnow=x[i]-j;
                if(xnow<x[0])break;//超出左边界
                if(dp[xnow]==inf)continue;//蜘蛛侠到达不了这个点
                int xnext=x[i]+j;
                xnext=min(xnext,x[n-1]);
                dp[xnext]=min(dp[xnext],dp[xnow]+1);
            }
        }
        if(dp[x[n-1]]==inf)puts("-1");
        else
        printf("%d\n",dp[x[n-1]]);
    }
    return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值