hdu 1305(字典树)注意本题的输入!!!

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 852    Accepted Submission(s): 453


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
  
  
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
  
  
Set 1 is immediately decodable Set 2 is not immediately decodable
//Trie树的性质:
//1. 根节点不包含字符,除根节点外每一个节点都只包含一个字符。 
//2. 从根节点到某一节点,路径上经过的字符连接起来,为该节点对应的字符串。 
//3. 每个节点的所有子节点包含的字符都不相同。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct Node{
    struct Node *child[2];
    int flag;//终止位置的标记
}Node,*Trie;
int path;
char str[19];
Trie root;
Trie newnode()
{//生成一个新的结点并进行初始化
    Trie temp;
    temp=(Trie)malloc(sizeof(Node));
    for(int i=0;i<2;i++)
        temp->child[i]=NULL;
    temp->flag=0;
    return temp;
}
void Insert()
{
    int i,len,index;
    Trie curn,newn;
    len=strlen(str);
    curn=root;
    for(i=0;i<len;i++)
    {
        index=str[i]-'0';
        if(curn->child[index]==NULL)//该字符没有出现过
        {
            path=0;//此路线未曾走过
            newn=newnode();
            curn->child[index]=newn;
        }
        curn=curn->child[index];//变换当前节点
        if(curn->flag)return;//边插入边判断

    }
    curn->flag=1;
}
int main()
{
    int result,cases;
    result=1;
    cases=1;
    root=newnode();
    while(scanf("%s",str)!=EOF)
    {
        if(str[0]=='9')
        {
            if(result)
                printf("Set %d is immediately decodable\n",cases++);
            else
                printf("Set %d is not immediately decodable\n",cases++);
            root=newnode();
            result=1;
            continue;


        }
        path=1;
        Insert();
        if(path==1)
            result=0;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值