阶乘问题


GCC

Time Limit:1000MS Memory Limit:65536K
Total Submit:64 Accepted:25

Description

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

Input

The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!) % m.
Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

Sample Input

1
10 861017

Sample Output

593846
题意:一看见n值那么大就蒙了觉得应该用大整数就放弃了,后来仔细看看原来n那么大没用,因为当n》m时候m后面的阶乘里面都有m这个因子对其取余为0,所以m后面的数就不用考虑了。然后就是如果把阶乘的和先算出来的话那么这个工程就太浩大了,所以要边算边求余,还有就是对n的输入要用字符串来输入,因为int最多表示10位。
#include<stdio.h>
int f[1000009];
int main()
{
    int t,sum,i,s,m;
	char str[109];
	scanf("%d",&t);
	while(t--)
	{
		getchar();
		scanf("%s",str);
		scanf("%d",&m);
		if(m==1){printf("0\n");continue;}
                s=0;
		for(i=0;str[i]!='\0';i++)//把字符数组转化为整数
		{
			s=s*10+str[i]-'0';
			if(s>=m)
			{
				s=m;
				break;
			}
		}
		f[0]=1;
		sum=1;
		for(i=1;i<=s;i++)//边计算边求余
		{
			f[i]=(i*f[i-1])%m;
			sum=(sum+f[i])%m;
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值