POJ3518Prime Gap(二分查找)

Prime Gap
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 10346 Accepted: 5953

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0

114

题意:输入一个实数,如果实数为素数,输出0,否则,输出实数后一个素数与前一个素数的差。

思路:是属于规定范围内的素数用二分查找寻找之间关系。

#include<cstdio>
#include<cmath>
#include<cstring>
#define Max 1299710
#define len 100001
int prime[len],cnt;
int num[Max];
void search_prime()
{
    cnt=1;
    memset(num,0,sizeof(num));
    for(int i=2;i<Max;i++)
    {
        if(num[i]==0)
        {
            prime[cnt++]=i;
            for(int j=i+i;j<Max;j+=i)
                num[j]=1;
        }
    }
    return;
}
int main()
{
    int n;
    search_prime();
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        int low=1,high=cnt-1,mid;
        while(low<=high)
        {
            mid=(low+high)/2;
            if(prime[mid]>n)
                high=mid-1;
            else if(prime[mid]<n)
                low=mid+1;
            else if(prime[mid]==n)
                break;
        }
        //int x=low;
        if(prime[mid]==n)
            printf("0\n");
        else
            printf("%d\n",prime[low]-prime[high]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值