POJ2253Frogger(最短路)

27 篇文章 0 订阅
17 篇文章 0 订阅
Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48889 Accepted: 15576

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2

Frog Distance = 1.414

题意:从第一个坐标到达第二个坐标的最长路径中的最小单步距离。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct stone
{
    double x,y;
}s[205];
int n;
double dis[205][205];
double dist(stone a,stone b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)
              +(a.y-b.y)*(a.y-b.y));
}
int main()
{
    int cnt=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(int i=1;i<=n;i++)
            scanf("%lf %lf",&s[i].x,&s[i].y);
        memset(dis,0,sizeof(dis));
        int num=0;
        for(int i=1;i<=n;i++)
        for(int j=1;j<i;j++)
            dis[i][j]=dis[j][i]=dist(s[i],s[j]);
       /* for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            printf("dis[%d][%d]=%lf\n",i,j,dis[i][j]);*/
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                dis[i][j]=min(max(dis[i][k],dis[k][j]),dis[i][j]);
//从k出发,有两个选择i,j,要使路径最大,选k到另一块石头的最大值,所以是max,
//选出来之后k到另一块石头就多了一个跳跃单步距离,所以要比较选最小的跳跃单步距离,
//所以max外是min
//dis下标用i,j来计数,i,j循环连续,标记二维数组不容易乱
        cnt++;
        printf("Scenario #%d\n",cnt);
        printf("Frog Distance = %.3lf\n\n",dis[1][2]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值