Rotation II(数学)

问题 H: Rotation II
时间限制: 1 Sec 内存限制: 128 MB
提交: 291 解决: 240
[提交] [状态] [讨论版] [命题人:admin]
题目描述

You are given a grid with 2 rows and 3 columns of squares. The color of the square at the i-th row and j-th column is represented by the character Cij.
Write a program that prints YES if this grid remains the same when rotated 180 degrees, and prints NO otherwise.

Constraints
Ci,j(1≤i≤2,1≤j≤3) is a lowercase English letter.

输入

Input is given from Standard Input in the following format:
C11C12C13
C21C22C23

输出

Print YES if this grid remains the same when rotated 180 degrees; print NO otherwise.

样例输入

pot
top

样例输出

YES

提示

This grid remains the same when rotated 180 degrees.
矩阵转180度

#include<bits/stdc++.h>
using namespace std;
int main()
{
    char a[2][3],b[2][3];
    for(int i=0;i<2;i++)
        for(int j=0;j<3;j++)
        cin>>a[i][j];
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<3;j++)
        {
            b[2-i-1][3-j-1]=a[i][j];
        }
    }
    int flag=0;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<3;j++)
        {
            if(a[i][j]!=b[i][j])
            {
                flag=1;
                break;
            }
        }
    }
    if(flag) cout<<"NO"<<endl;
    else cout<<"YES"<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值