PAT 1009 Product of Polynomials(模拟)

前言

多项式的乘法,模拟暴力打。

题目概述

1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

AC代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 1e6 + 10;

int n;

double res[N];
using PII = pair<int, double>;

vector<PII> p1, p2;

void read(vector<PII> &p)
{
    
}
int main()
{
    cin >> n;
    for(int i = 0; i < n; ++i)
    {
        int a;
        double b;
        cin >> a >> b;
        p1.push_back({a, b});
    }
    cin >> n;
    for(int i = 0; i < n; ++i)
    {
        int a;
        double b;
        cin >> a >> b;
        p2.push_back({a, b});
    }
    
    for(auto c : p1)
    {
        int a = c.first;
        double b = c.second;
        
        for(auto v : p2)
        {
            int c = v.first;
            double d = v.second;
            
            int e = c + a;
            double cnt = b * d;
            res[e] += cnt;
        }
    }
    
    bool front = true;
    
    int k = 0;
    for(int i = 1e6; i >= 0; --i)
    {
        if(res[i]) ++k;
    }
    
    cout << k;
    for(int i = 1e6; i >= 0; --i)
    {
        if(res[i]) printf(" %d %.1lf", i, res[i]);
    }
    
    return 0;
}

分析思路

1.模拟手算多项式的方法,每项对应相乘即可。开一个散列存储对应次数的项的系数。

文末广告

学习算法和数据结构真的是个很累的过程,不会做只能求助于题解。 因为写代码这个东西基本上是千人千面。同时网络上搜到的题解很多要么用到的是自己还没学到的知识,看不懂;要么内核过于简陋,只能糊弄当前题目,不具有普适性。
如果你是一个喜欢做洛谷,ACwing和PTA的题目的同学,欢迎关注我的博客,我主要在这三个平台上做题,认为有价值和有难度的题目我会写题解发布出来。

TreeTraverler的往期文章

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

102101141高孙炜

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值