HDU4252:A Famous City

Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building, or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.
 

Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the input numbers will be nonnegative and less than 1,000,000,000.
 

Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 

Sample Input
  
  
3 1 2 3 3 1 2 1
 

Sample Output
  
  
Case 1: 3 Case 2: 2
Hint
The possible configurations of the samples are illustrated below:
 


 

这道题算是比较难理解的了

题意:
一张相片上的很多建筑相互遮住了,根据高低不同就在相片上把一座高楼的可见部分作为一个矩形,
并用数字描述其高度,若一张相片上的两个建筑群中间有空地,高度则为0;求最少有多少个建筑;
思路:
1 2 1最少为2座,因为2把1挡住了,而3 1 3则为3座,1挡不住3;
如:1 2 3 1 2 3 0 1
输入的0不是建筑,则输入的总个数减去0的个数就是最多可能有的建筑数,设为s;
再从第一个开始从前往后搜,若发现比它高的则继续搜,若发现比它低的则说明它是一个独立的建筑,
这时可以返回搜其它的;若与它相等,说明这时它们还没有出现比它们低的建筑,则视其为同一个建筑,
则s减1;

 

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[1000005],x,len;

int main()
{
    int n,i,cas = 1,ans,j;
    while(~scanf("%d",&n))
    {
        ans = 0;
        for(i = 0; i<n; i++)
            scanf("%d",&a[i]);
        if(a[0]==0)
            ans++;
        for(i = 1; i<n; i++)
        {
            if(a[i]==0)
                ans++;
            else
            {
                for(j = i-1; j>=0; j--)
                {
                    if(a[i]>a[j])
                        break;
                    else if(a[i]==a[j])
                    {
                        ans++;
                        break;
                    }
                }
            }
        }
        printf("Case %d: %d\n",cas++,n-ans);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值