FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 60861 Accepted Submission(s): 20491
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
Sample Output
13.333 31.500
Author
CHEN, Yue
Source
贪心即可,使用排序将J[i]/F[i]比值大的放在前面,从头开始加入,直到总量满足要求。
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1001;
struct Trade{
double f,j;
double u;
}t[maxn];
bool cmp(Trade a,Trade b){
return a.u > b.u;
}
int main(){
int n;
double m;
while(1){
cin >> m >> n;
if(n==-1) break;
for(int i = 0;i < n;i++){
cin >> t[i].j >> t[i].f;
t[i].u = t[i].j/t[i].f;
}
sort(t,t+n,cmp);
int index = 0;
double ans = 0;
for(int i = 0;i < n;i++){
if(m>t[i].f){
ans += t[i].j;
m -= t[i].f;
} else {
ans += m*t[i].u;
break;
}
}
printf("%.3f\n",ans);
}
return 0;
}