队列的in和out

ACboy needs your help again!

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 22   Accepted Submission(s) : 15

Problem Description

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

 

 

Input

The input contains multiple test cases. The first line has one integer,represent the number oftest cases. And the input of each subproblem are described above.

 

 

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

 

 

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

 

Sample Output

1
2
2
1
1
2
None
2
3
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<queue>
#include<stack>
using namespace std;
#define TRUE 1
#define FALSE 0
#define OK 1
#define ERROR 0
#define INFEASIBLE -1  
#define OVERFLOW -2

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
    	stack<int> s;
    	queue<int> q;
    	int n,k;
    	char str[6],s1[5];
    	scanf("%d %s",&n,str);
    	if(strcmp(str,"FIFO")==0)//队列,先进先出 
    	{
    		while(n--)
    		{
    			getchar();
    			scanf("%s",s1);
    			if(s1[0]=='I')
    			{
    				scanf("%d",&k);
    				q.push(k);
				}
				else if(s1[0]=='O')
				{
					if(q.empty())
					    printf("None\n");
	                else
	                {
	                	printf("%d\n",q.front());
	                	q.pop();
					}
				}
			}
		}
		else if(strcmp(str,"FILO")==0)//栈,先进后出 
		{
			while(n--)
			{
				getchar();
				scanf("%s",s1);
				if(s1[0]=='I')
				{
					scanf("%d",&k);
					s.push(k);
				}
				else if(s1[0]=='O')
				{
					if(s.empty())
					    printf("None\n");
	                else 
	                {
	                	printf("%d\n",s.top());
	                	s.pop();
					}
				}
			}
		}
	}
    return 0;
}

这题是简单的栈和队列的调用,符合栈先进后出和队列先进先出的特点。这次的代码直接调用stack模板类和queue模板类,没有在main函数中写其中的基本操作,使代码简洁许多。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值