Girls and Boys 【最大独立集团】

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11291 Accepted Submission(s): 5293

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output
5
2

Source
Southeastern Europe 2000
思路: 找最大独立集合 ==图中点的个数 – 最大匹配数目
代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 1000+110
#define MOD 100000007
#define LL long long
int used[M];
int mapp[M][M];
int pipei[M];
    int n;
int find(int x)
{
    int i,j;
    for(i=0;i<n;i++)
    {
        if(!used[i]&&mapp[x][i])
        {
                used[i]=1;
            if(pipei[i]==-1||find(pipei[i]))
            {
                pipei[i]=x;
                return 1;
            }
        }
    }
    return 0;
 } 
int main()
{

    while(~scanf("%d",&n))
    {
        int i,j;
        memset(mapp,0,sizeof(mapp));
        memset(pipei,-1,sizeof(pipei));
        for(i=0;i<n;i++)
        {
            int a,num;
            scanf("%d: (%d)",&a,&num);
            while(num--)
            {
                int b;
                scanf("%d",&b);
                mapp[a][b]=1;  // 单向的 
            }
        }
        int sum=0;
        for(i=0;i<n;i++) 
        {
            memset(used,0,sizeof(used));
            if(find(i)) sum++;
         } 

         printf("%d\n",n-sum/2);  //最大独立集团 的个数 
    } // 因为这个是 一个序列 和自身序列的匹配肯定会重复 ,

    return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值