BigNumber_1

A - BigNumber_1
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. 
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) 
Your task is to take a number as input, and print that Fibonacci number. 
 

Input

Each line will contain an integers. Process to end of file. 
 

Output

For each case, output the result in a line.
 

Sample Input

       
       
100
 

Sample Output

       
       
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

PS:大数相加+斐波那契数列


代码:

#include<iostream>
#include<string>
using namespace std;

int ns[2100] = { 0 };

string add(string sa, string sb)
{
	string sa1, sb1;
	sa1 = sa;
	sb1 = sb;
	int la = sa.length();
	int lb = sb.length();
	if (la < lb)
	{
		string tmps = sa;
		sa = sb;
		sb = tmps;
		int tmpi;
		tmpi = la;
		la = lb;
		lb = tmpi;
	}
	string st = "";
	for (int j = lb; j < la; ++j)
	{
		st += '0';
	}
	st += sb;
	sb = st;
	int num = 0, k = 0;
	for (int m = la - 1; m >= 0; --m)
	{
		int sum = (sa[m] - '0') + (sb[m] - '0') + num;
		ns[k++] = sum % 10;
		num = sum / 10;
	}
	if (num > 0)
	{
		ns[k++] = num;
	}
	string str = "";
	for (int j = k - 1; j >= 0; --j)
	{
		str += (ns[j] + '0');
	}
	return str;
}

int main()
{
	string f[7101];
	f[1] = f[2] = f[3] = f[4] = "1";
	for (int i = 5; i < 7101; ++i)
	{
		f[i] = add(add(f[i - 1], f[i - 2]), add(f[i - 3], f[i - 4]));
	}
	int num;
	while (cin >> num)
	{
		cout << f[num] << endl;
		//cout << f[num].length() << endl;
	}

	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值