PAT——1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

思路:本题目根据邻接矩阵,利用dijkstra算法求最短路径的题。

需要解决:

  1. dijkstra算法
  2. 多条最短路径,选择路径中,节点和最大的一条
  3. 遍历路径

dijkstra算法图文讲解参考:https://blog.csdn.net/lbperfect123/article/details/84281300

多条最短路径,要对访问的前一个节点进行记录,然后用DFS遍历路径,求得所有节点和最大的路径。

#include <iostream>
#include <stdio.h>
#include <vector>
using namespace std;

int n, m, c1, c2;
const int inf = 9999999;
int num[501];
vector<vector<int> > pre_city(501);//记录每个节点的前一个节点,用DFS遍历可得到路径
vector<int> tmp_path;//访问路径
int e[501][501];//邻接矩阵
int d[501];/*路径最小值*/
int visited[501] = {0};
int num_path = 0, maxx = 0;

void input()
{
    cin >> n >> m >> c1 >> c2;
    for(int i = 0; i < n; i++)
    {
        cin >> num[i];
    }
    for(int i = 0; i < m; i++)
    {
        int x,y,w;
        cin >> x >> y >> w;
        e[x][y] = e[y][x] = w;
    }
    //初始化对角线为0
    for(int i = 0; i < n; i++)
        e[i][i] = 0;
}

void DFS(int start, int ends)
{
    tmp_path.push_back(start);
    if(start == ends)
    {
        num_path++;
        int sum = 0;
        for(int i = tmp_path.size() - 1; i >= 0; i--)
        {
            sum += num[tmp_path[i]];
        }
        if(sum > maxx)
            maxx = sum;
        tmp_path.pop_back();
        return;
    }

    for(int i = 0; i < pre_city[start].size(); i++)
        DFS(pre_city[start][i], ends);
    tmp_path.pop_back();
}

void dijkstra_path()
{
    for(int i = 0; i < n; i++)
    {
        if(e[c1][i] != inf)
        {
            d[i] = e[c1][i];
            pre_city[i].push_back(c1);
        }
    }
    visited[c1] = 1;
    for(int i = 0; i < n; i++)
    {
        /*for1, 查找路径最小值*/
        int minn = inf, k;
        for(int j = 0; j < n; j++)
        {
            if(!visited[j] && d[j] < minn)
            {
                minn = d[j];
                k = j;
            }
        }
        visited[k] = 1;
        /*for2, 中间点k到未找过的边集v,是否更小*/
        for(int v = 0; v < n; v++)
        {
            if(!visited[v] && d[v] > d[k] + e[k][v])
            {
                d[v] = d[k] + e[k][v];
                pre_city[v].clear();
                pre_city[v].push_back(k);
            }
            else if(!visited[v] && d[v] == d[k] + e[k][v])
                pre_city[v].push_back(k);
        }
    }

    DFS(c2, c1);
}

void output()
{
    cout << num_path << " " << maxx;
}

int main()
{
    /*1003 Emergency (25 分)*/
    fill(num, num+501, 0);
    fill(e[0], e[0]+501*501, inf);
    fill(d, d+501, inf);
    input();

    dijkstra_path();

    output();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值