hdu 4336 期望 状压dp

5 篇文章 0 订阅
3 篇文章 0 订阅

Card Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2478 Accepted Submission(s): 1163
Special Judge

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

Sample Input
  
  
1 0.1 2 0.1 0.4

Sample Output
  
  
10.000 10.500


题意:有n张卡片,每张卡片都有一定的几率通过买一包零食抽到,但也有零食里没有卡片,问要集齐n张卡,需要买的零食期望数是多少

思路:因为最终集齐所有卡片剩余需要买的零食的期望肯定是0,所以可以以终点为起点推到一开始手上一张卡都没有的状态。用dp[i]表示从该状态到最后全部集齐所需要的零食数,主要需要解决的是i是怎么表示。因为卡片总共只有20种,所以可以用状压来表示状态,1表示该卡片已有。则dp[(1<<n)-1]=0即全部都集齐的状态,dp[0]为一张卡片都没有,所以用它表示集齐所有需要的零食期望。

dp[i]=_p(dp[i]+1)+∑pk*(dp[i]+1)+∑pj*(dp[j]+1)

_p:一张卡片都没抽到的概率

pk:表示抽到的卡片当前状态已有

pj:表示该卡当前状态没有

#include<cstdio> 
#include<cstring> 
#include<algorithm> 
using namespace std; 
double p[25];
double dp[1<<20];

int main(void){
	int n;
	double _p;
	while(~scanf("%d",&n)){
		_p=0;
		for(int i=0;i<n;i++){
			scanf("%lf",&p[i]);
			_p+=p[i];
		}
		_p=1-_p;	
		memset(dp,0,sizeof(dp));
		for(int i=(1<<n)-2;i>=0;i--){
			dp[i]=1.0;
			double sum=_p;
			for(int j=0;j<n;j++)
				if((1<<j)&i) sum+=p[j];
				else dp[i]+=p[j]*dp[i|(1<<j)];
			dp[i]/=(1.0-sum);
		}
		printf("%.5f\n",dp[0]);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值