1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 3 3.6 2 6.0 1 1.6


题意,简单题,求两个多项式相乘,看了晴神的书以后发现可以优化,结构体只要一个数组,然后一个结果的double数组


ac:#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>


using namespace std;


struct Poly{
double coef;
int expo;
}poly1[11],poly2[11],ans[100];


int map[2005];   //检测expo是否出现过 出现的下标 
bool cmp(Poly p1,Poly p2){
if(p1.expo>p2.expo) return true;
return false;
}
int main(){
int k1,k2;
//freopen("D:\\input.txt","r",stdin);
memset(map,-1,sizeof(map));
cin>>k1;


for(int i=0;i<k1;i++){
cin>>poly1[i].expo>>poly1[i].coef;
}

cin>>k2;
for(int i=0;i<k2;i++){
cin>>poly2[i].expo>>poly2[i].coef;
}
Poly temp; int m=0;
for(int i=0;i<k1;i++){
for(int j=0;j<k2;j++){
temp.coef=poly1[i].coef*poly2[j].coef;
temp.expo=poly1[i].expo+poly2[j].expo;

if(map[temp.expo]==-1){
map[temp.expo]=m;
ans[m].coef=temp.coef;
ans[m].expo=temp.expo;
m++;
}
else{
int index=map[temp.expo];
ans[index].coef+=temp.coef;
}
}
}
    
sort(ans,ans+m,cmp);
int cnt=0;
for(int i=0;i<m;i++){
if(ans[i].coef!=0) cnt++;
}
printf("%d",cnt);
for(int i=0;i<m;i++){
if(ans[i].coef!=0.0){
printf(" %d %.1lf",ans[i].expo,ans[i].coef);
}
}


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值