PAT (Advanced Level) Practice 1007

1007 Maximum Subsequence Sum (25)(25 point(s))

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意:求最大的子序列和的值,这里就是需要记录一下起始的角标,方便因为答案需要输出指定角标下的具体数值。(刚开始写,题意理解错了,把它理解为需要输出i和j角标值)

code

#include<cstdio>
int main(){
	int seq[100001];
	int n;
	scanf("%d", &n);
	int sum = 0, c = 0, max = -1;
	int posi = 0,posj = 0;
	for(int i = 0;i < n;i++){
		scanf("%d", &seq[i]);
		if(sum + seq[i] >= 0){//这里需要大于等于0 ,因为一个0也可以为最大值,没有等号有一个样例通不过 
			c++;
			sum += seq[i];
			if(sum > max){//判断此时子串和是否比最大值大,如果是,那么记录角标。 
				max = sum;
				posi = i - c + 1;
				posj = i;
			}
		}else{//如果发现子串和小于0,那么不需要继续累加,直接重置数据。 
			c = 0;
			sum = 0;
		}
	} 
	if(max == -1){
		printf("%d %d %d", 0, seq[0], seq[n-1]);
	}else{
		printf("%d %d %d", max, seq[posi], seq[posj]);
	} 
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值