【PAT】A1121 Damn Single【散列】

该编程题目要求找出大型聚会中没有伴侣的单身人士,输入包括夫妻对数及聚会嘉宾ID,输出单身者数量及其ID。通过建立配偶关系并检查每个ID的伴侣是否存在来解决此问题。
摘要由CSDN通过智能技术生成

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

题意

给出若干对夫妻以及一个party上的所有成员,求party中所有的单身狗(一对夫妻只来了一个也属于单身),要求按ID从小到大输出。

思路

简单模拟即可。用couple[i] = j表示i的配偶是j(如果i是单身,则j为-1)。具体逻辑看代码注释。

代码

#include <cstdio>
#include <algorithm>
#define MAX_ID 1000000
#define MAX_M 10000
using namespace std;
int couples[MAX_ID], idInPart[MAX_M], single[MAX_M];
bool inPart[MAX_ID];
int main() {
    fill(couples, couples + MAX_ID, -1);// 初始化为-1,代表每个人都是单身
    fill(inPart, inPart + MAX_ID, false);
    
    // couples[a] = b 表示a的配偶是b
    int N;
    scanf("%d", &N);
    for(int i = 0, a, b; i < N; i++){
        scanf("%d %d", &a, &b);
        couples[a] = b;
        couples[b] = a;
    }
    
    
    // 边读入Party成员边分别标记该成员是否在party上,同时存储party的成员
    int M;
    scanf("%d", &M);
    for(int i = 0, t; i < M; i++){
        scanf("%d", &t);
        inPart[t] = true;
        idInPart[i] = t;
    }
    
    // 遍历party成员,如果该成员是单身的,或者他的配偶不在party上,则他是单身的
    int cnt = 0;
    for(int i = 0, t; i < M; i++){
        t = idInPart[i];
        if(couples[t] == -1 || !inPart[couples[t]]){
            single[cnt++] = t;
        }
    }
    
    // 排序
    sort(single, single + cnt);
    
    // 输出结果
    printf("%d\n", cnt);
    for(int i = 0; i < cnt; i++){
        if(i > 0) putchar(' ');
        printf("%05d", single[i]);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值