(PAT 1121) Damn Single (哈希)

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

解题思路:

利用哈希思想解决,创建三个哈希表,一个用来保存此人得配偶,一个用来保存此人是否已婚,最后一个用来保存此人是否在派对上

判断是否单身时,先判断此人是否已婚,如果已婚,判断此人得配偶是否在派对上,查表即可

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXN = 100010;
int N, M;
int marrigeHash[MAXN];
bool isMArrage[MAXN] = { false };
bool atParty[MAXN] = { false };
int guestesOnline[MAXN];
vector<int> singleList;
int main() {
	//初始化
	fill(marrigeHash, marrigeHash + MAXN, -1);
	cin >> N;
	int couple1, couple2;
	for (int i = 0; i < N; ++i){
		cin >> couple1 >> couple2;
		marrigeHash[couple1] = couple2;
		marrigeHash[couple2] = couple1;
		isMArrage[couple1] = true;
		isMArrage[couple2] = true;
	}
	cin >> M;
	for (int i = 0; i < M; ++i) {
		cin >> guestesOnline[i];
		atParty[guestesOnline[i]] = true;
	}
	for (int i = 0; i < M; ++i) {
		if (!isMArrage[guestesOnline[i]]) {
			singleList.push_back(guestesOnline[i]);
		}
		else {
			if (!atParty[marrigeHash[guestesOnline[i]]]) {
				singleList.push_back(guestesOnline[i]);
			}
		}
	}
	sort(singleList.begin(), singleList.end());
	cout << singleList.size() << endl;
	for (int i = 0; i < singleList.size(); ++i) {
		printf("%05d", singleList[i]);
		if (i < singleList.size() - 1) cout << " ";
	}
	system("PAUSE");
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值