"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.
Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
思路:
给N对夫妻编号,再给M个派对里的参与人的编号,输出单身的人的编号(包括夫妻没全部到场的也算单身)
C++:
#include "map"
#include "iostream"
#include "set"
#include "cstdio"
using namespace std;
int n,m;
int main(){
scanf("%d",&n);
map<int,int> couples;
for (int i=0;i<n;i++)
{
int a,b;
scanf("%d %d",&a,&b);
couples[a]=b;
couples[b]=a;
}
scanf("%d",&m);
set<int> attend,single;
for (int i=0;i<m;i++)
{
int a;
scanf("%d",&a);
attend.insert(a);
}
for (auto it=attend.begin();it!=attend.end();it++)
{
int couple=couples[(*it)];
auto res=attend.find(couple);
if (res==attend.end())single.insert((*it));
}
printf("%d\n",single.size());
for (auto it=single.begin();it!=single.end();it++)
{
if (it!=single.begin())printf(" ");
printf("%05d",*it);
}
return 0;
}