A Simple Problem with Integers

Problem Description

Let A1, A2, ... , AN be N elements. You need to deal with two kinds of operations. One type of operation is to add a given number to a few numbers in a given interval. The other is to query the value of some element.

Input

There are a lot of test cases. 
The first line contains an integer N. (1 <= N <= 50000)
The second line contains N numbers which are the initial values of A1, A2, ... , AN. (-10,000,000 <= the initial value of Ai <= 10,000,000)
The third line contains an integer Q. (1 <= Q <= 50000)
Each of the following Q lines represents an operation.
"1 a b k c" means adding c to each of Ai which satisfies a <= i <= b and (i - a) % k == 0. (1 <= a <= b <= N, 1 <= k <= 10, -1,000 <= c <= 1,000)
"2 a" means querying the value of Aa. (1 <= a <= N)

Output

For each test case, output several lines to answer all query operations.

Sample Input

4 
1 1 1 1
14
2 1
2 2
2 3
2 4
1 2 3 1 2
2 1 
2 2
2 3
2 4
1 1 4 2 1
2 1
2 2
2 3
2 4

Sample Output

1
1
1
1
1
3
3
1
2
3
4
1
 
 
 
 
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<cstdio>
int tree[12][12][50010];
int a[50010],n;

int lowbit(int x)
{
    return (x&-x);
}
void update(int k,int mod,int border,int val)
{
    while(border>0)
    {
        tree[k][mod][border]+=val;
        border=border- lowbit(border);
    }
}
int sum(int k,int mod,int border)
{
    int s=0;
    while(border<=n)
    {
        s+=tree[k][mod][border];
        border=border + lowbit(border);
    }
    return s;
}

int main()
{
    //freopen("a.in","r",stdin);

    int i,m,s,t,l,r,k,val;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(tree,0,sizeof(tree));
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&t);
            if(t==1)
            {
                scanf("%d %d %d %d",&l,&r,&k,&val);
                update(k,l%k,r,val);
                update(k,l%k,l-1,-val);
            }else
            {
                scanf("%d",&l);
                s=a[l];
                for(i=1;i<=10;i++)
                {
                    s+=sum(i,l%i,l);
                }
                printf("%d\n",s);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值