HDU1728-逃离迷宫

28 篇文章 0 订阅
逃离迷宫
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,  
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x   1, y   1, x   2, y   2  (1 ≤ k ≤ 10, 1 ≤ x   1, x   2  ≤ n, 1 ≤ y   1, y   2  ≤ m),其中k表示gloria最多能转的弯数,(x   1, y   1), (x   2, y   2)表示两个位置,其中x   1,x   2对应列,y   1, y 2对应行。  
 

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input

       
       
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output

       
       
no yes

#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>

using namespace std;

int n1,n2,k;
char map[105][105];
int visit[105][105];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};

struct node
{
    int x,y,turn;
};

int check(int x,int y)
{
    if(1<=x&&x<=n1&&1<=y&&y<=n2&&map[x][y]=='.')  return 1;
    else return 0;
}

void bfs(node s1,node s2)
{
    queue<node>q;
    node pre,next;
    int i,nextx,nexty;
    pre.x=s1.x;pre.y=s1.y;pre.turn=-1;
    q.push(pre);
    while(!q.empty())
    {
        pre=q.front();
        q.pop();
        for(i=0;i<4;i++)
        {
            nextx=pre.x+dir[i][0];
            nexty=pre.y+dir[i][1];
            while(check(nextx,nexty))
            {
                if(!visit[nextx][nexty])
                {
                    visit[nextx][nexty]=1;
                    next.x=nextx;
                    next.y=nexty;
                    next.turn=pre.turn+1;
                    if(next.x==s2.x&&next.y==s2.y&&next.turn<=k)
                    {
                        printf("yes\n");
                        return ;
                    }
                    q.push(next);
                }
                nextx+=dir[i][0];
                nexty+=dir[i][1];
            }
        }
    }
    printf("no\n");
}

int main()
{
    int i,j,t;
    node s1,s2;
    scanf("%d",&t);
    while(t--)
    {
        memset(visit,0,sizeof(visit));
        scanf("%d%d",&n1,&n2);
        for(i=1;i<=n1;i++)
        {
            getchar();
            for(j=1;j<=n2;j++)
                scanf("%c",&map[i][j]);
        }
        scanf("%d%d%d%d%d",&k,&s1.y,&s1.x,&s2.y,&s2.x);
        if(s1.x==s2.x&&s1.y==s2.y) printf("yes\n");
        else bfs(s1,s2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值