HDU5775-Bubble Sort

Bubble Sort

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                       Total Submission(s): 1148    Accepted Submission(s): 643


Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i)
    for(int j=N,t;j>i;—j)
        if(P[j-1] > P[j])
            t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case. 
 

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
 

Sample Input
  
  
2 3 3 1 2 3 1 2 3
 

Sample Output
  
  
Case #1: 1 1 2 Case #2: 0 0 0
Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.
 

Author
FZU
 

Source


题意:求出1-n里面各个数在冒泡排序里面可以达到的最右距离和最左距离之差是多少

解题思路:最右边的位置是初始位置加上比它小的个数,最左边的位置min(初始位置和,最终位置)



#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>

using namespace std;

int tree[100005],a[100005],b[100005];
int n;

int low(int x)
{
    return x&-x;
}

int sum(int x)
{
    int s=0;
    while(x>0)
    {
        s+=tree[x];
        x-=low(x);
    }
    return s;
}

void add(int a,int b)
{
    while(a<=n)
    {
        tree[a]+=b;
        a+=low(a);
    }
    return ;
}

int main()
{
    int t,cas=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(tree,0,sizeof tree);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=n;i>=1;i--)
        {
            int ans=sum(a[i]);
            add(a[i],1);
            b[a[i]]=i+ans-min(a[i],i);
        }
        printf("Case #%d:",++cas);
        for(int i=1;i<=n;i++)
            printf(" %d",b[i]);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值