HDU4000-Fruit Ninja

Fruit Ninja

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                       Total Submission(s): 2314    Accepted Submission(s): 909

Problem Description
Recently, dobby is addicted in the Fruit Ninja. As you know, dobby is a free elf, so unlike other elves, he could do whatever he wants.But the hands of the elves are somehow strange, so when he cuts the fruit, he can only make specific move of his hands. Moreover, he can only start his hand in point A, and then move to point B,then move to point C,and he must make sure that point A is the lowest, point B is the highest, and point C is in the middle. Another elf, Kreacher, is not interested in cutting fruits, but he is very interested in numbers.Now, he wonders, give you a permutation of 1 to N, how many triples that makes such a relationship can you find ? That is , how many (x,y,z) can you find such that x < z < y ?
 
Input
The first line contains a positive integer T(T <= 10), indicates the number of test cases.For each test case, the first line of input is a positive integer N(N <= 100,000), and the second line is a permutation of 1 to N.
 
Output
For each test case, ouput the number of triples as the sample below, you just need to output the result mod 100000007.
 
Sample Input
  
  
2 6 1 3 2 6 5 4 5 3 5 2 4 1
 
Sample Output
  
  
Case #1: 10 Case #2: 1
 
Source

        题意:给出n个数,求所有的i<j<k且a[i]<a[k]<a[j]的个数

          解题思路:对每个位置考虑后面有多少比他大的数,则这个小的后面跟两个大的个数为x(x-1)/2,然后肯定要减去后面的所有组成的i<j<k且a[i]<a[j]<a[k]的个数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#include <algorithm>

using namespace std;

int n;
int cnt[100005];

int lowbit(int x)
{
    return x&(-x);
}

void update(int x)
{
    while(x<=n)
    {
        cnt[x]++;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int sum=0;
    while(x>0)
    {
        sum+=cnt[x];
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    int t,cas=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(cnt,0,sizeof(cnt));
        scanf("%d",&n);
        long long int ans=0;
        for(int i=1;i<=n;i++)
        {
            int a;
            scanf("%d",&a);
            update(a);
            long long int qian=sum(a-1);
            long long int hou=(n-a)-(i-1-qian);
            ans=ans-qian*hou+(hou*(hou-1))/2;
        }
        printf("Case #%d: %I64d\n",++cas,ans%100000007);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值