hdu 4000 Fruit Ninja 求数组中 小大中 的个数

Problem Description
Recently, dobby is addicted in the Fruit Ninja. As you know, dobby is a free elf, so unlike other elves, he could do whatever he wants.But the hands of the elves are somehow strange, so when he cuts the fruit, he can only make specific move of his hands. Moreover, he can only start his hand in point A, and then move to point B,then move to point C,and he must make sure that point A is the lowest, point B is the highest, and point C is in the middle. Another elf, Kreacher, is not interested in cutting fruits, but he is very interested in numbers.Now, he wonders, give you a permutation of 1 to N, how many triples that makes such a relationship can you find ? That is , how many (x,y,z) can you find such that x < z < y ?
 


 

Input
The first line contains a positive integer T(T <= 10), indicates the number of test cases.For each test case, the first line of input is a positive integer N(N <= 100,000), and the second line is a permutation of 1 to N.
 


 

Output
For each test case, ouput the number of triples as the sample below, you just need to output the result mod 100000007.
 


 

Sample Input
  
  
2 6 1 3 2 6 5 4 5 3 5 2 4 1
 


 

Sample Output
  
  
Case #1: 10 Case #2: 1

 

//小中大+小大中=sigma  (rightmax-1)*rightmax/2=total

//小中大 = sigma  leftmin*rightmax

//小大中=total-小中大

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=110000;
const int mod=100000007;
int c[maxn];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int val)
{
    for(int i=x;i<=n;i+=lowbit(i))
    {
        c[i]+=val;
    }
}
int sum(int x)
{
    int cnt=0;
    for(int i=x;i>=1;i-=lowbit(i))
    {
        cnt+=c[i];
    }
    return cnt;
}
int a[maxn];
long long leftmin[maxn],rightmax[maxn];
int main()
{
    int ci,pl=1;scanf("%d",&ci);
    while(ci--)
    {
        scanf("%d",&n);
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            leftmin[i]=sum(a[i]);
            update(a[i],1);
        }
        memset(c,0,sizeof(c));
        for(int i=n;i>=1;i--)
        {
            rightmax[i]=sum(n)-sum(a[i]);
            update(a[i],1);
        }
        for(int i=1;i<=n;i++)
        {
            long long tmp=((rightmax[i]-1)*rightmax[i]/2)%mod;
            long long cnt=(leftmin[i]*rightmax[i])%mod;
            long long tnow=((tmp-cnt)%mod+mod)%mod;
            ans=(ans+tnow)%mod;
        }
        printf("Case #%d: %I64d\n",pl++,ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值