POJ2115-C Looooops

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24045 Accepted: 6667

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source


题意:给出一个for循环语句,for(i=A ; i!=B ;i +=C),问循环几次能结束。这个是建立在变量是无符号k位的,即变量的数值在0到2的k次方之间,当超过2的k此方时,会溢出,也就是对2的k次方取余只有这样才有可能在有限次循环下结束。

解题思路:通过这个for循环可以看出本题是求B-A+(2^k)*y=C*x求x的问题。只要x有确定解就输出,无解就输出FOREVER。然后就转换成了C*x=(B-A)mod(2^k),求出最小的正整数x。


#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;

#define ll long long

ll exgcd(ll a,ll b,ll &x,ll &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    ll d=exgcd(b,a%b,x,y);
    ll tmp=x;
    x=y;
    y=tmp-(a/b)*y;
    return d;
}

int main()
{
    ll a,b,c,k,k1,x,y;
    while(~scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&k))
    {
        if(a==0&&b==0&&c==0&&k==0) break;
        k1=1;
        while(k--)
            k1*=2;
        if(b==a) {printf("0\n");continue;}
        ll d=exgcd(c,k1,x,y);
        if((b-a)%d)
        {
            printf("FOREVER\n");continue;
        }
        x=x*(b-a)/d;
        y=y*(b-a)/d;
        if(x>=0)
            x%=(k1/d);
        else
            x=x%(k1/d)+k1/d;
        printf("%lld\n",x);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值