HDU1587-Flowers

234 篇文章 1 订阅

Flowers

                                                                             Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                        Total Submission(s): 3983    Accepted Submission(s): 2630


Problem Description
As you know, Gardon trid hard for his love-letter, and now he's spending too much time on choosing flowers for Angel.
When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers. 
"How can I choose!" Gardon shouted out.
Finally, Gardon-- a no-EQ man decided to buy flowers as many as possible.
Can you compute how many flowers Gardon can buy at most?  

Input
Input have serveral test cases. Each case has two lines.
The first line contains two integers: N and M. M means how much money Gardon have.
N integers following, means the prices of differnt flowers.  

Output
For each case, print how many flowers Gardon can buy at most.
You may firmly assume the number of each kind of flower is enough.  

Sample Input
  
  
2 5 2 3  

Sample Output
  
  
2
Hint
Hint
Gardon can buy 5=2+3,at most 2 flower, but he cannot buy 3 flower with 5 yuan.  

Author
DYGG  

Source
 

题意:有n种花和m的钱,求最多可以买多少花的数量

解题思路:只要买最便宜的花就行了。


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int main()
{
    int n,m,x,mi;
    while(~scanf("%d %d",&n,&m))
    {
        mi=INF;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            mi=min(mi,x);
        }
        printf("%d\n",m/mi);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值