HDU 1587 Flowers【简单题】

156 篇文章 0 订阅
22 篇文章 0 订阅

/*
中文题目
题目大意:n种花,m块钱,求解最多可以买多少朵花
解题思路:排序,找出最便宜的花,在用总价钱除以最便宜的单价
解题人:lingnichong
解题时间:2014-09-03 22:20:34
解题体会:简单题
*/


Flowers

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2779    Accepted Submission(s): 1856


Problem Description
As you know, Gardon trid hard for his love-letter, and now he's spending too much time on choosing flowers for Angel.
When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers. 
"How can I choose!" Gardon shouted out.
Finally, Gardon-- a no-EQ man decided to buy flowers as many as possible.
Can you compute how many flowers Gardon can buy at most?
 

Input
Input have serveral test cases. Each case has two lines.
The first line contains two integers: N and M. M means how much money Gardon have.
N integers following, means the prices of differnt flowers.
 

Output
For each case, print how many flowers Gardon can buy at most.
You may firmly assume the number of each kind of flower is enough.
 

Sample Input
  
  
2 5 2 3
 

Sample Output
  
  
2
Hint
Hint
Gardon can buy 5=2+3,at most 2 flower, but he cannot buy 3 flower with 5 yuan.
 


#include<stdio.h> 
#include<algorithm>
using namespace std;
int a[10000];
int main()
{
    int n,m;
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        sort(a,a+n);
        printf("%d\n",m/a[0]);
    }    
    return 0;
}    





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值