ZOJ3333-Guess the Price

120 篇文章 1 订阅

Guess the Price

Time Limit: 1 Second       Memory Limit: 32768 KB

In the television program "Shopping Street" of CCTV-2, two people, A and B are guessing price of a given item. You are asked to decide whose price is closer to the real price.

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains three integers in one line: PPAPB (0 <= PAPB <= P <= 100, PA != PB), indicating the real price, the price A guesses and the price B guesses.

Output

For each case, output "A" or "B" according to whose price is closer to the real price.

Sample Input

3
10 8 7
20 20 19
100 9 50

Sample Output

A
A
B

Author:  HANG, Hang
Source:  The 7th Zhejiang Provincial Collegiate Programming Contest


题意:给出一个数,有两个人各猜了个不同的数,问谁猜的和这个数更近


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;
const int MAX=100009;

int main()
{
    int n,x,y;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&n,&x,&y);
        if(abs(n-x)<abs(n-y)) printf("A\n");
        else printf("B\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值