ZOJ3329-One Person Game

One Person Game

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

Author:  CAO, Peng
Source:  The 7th Zhejiang Provincial Collegiate Programming Contest


题意:有三个骰子,分别有K1,K2,K3个面,一次投掷可以得到三个骰子点数加和的分数,但是,当骰子1等于A,骰子2=B,骰子3=C时,结果清零。问从0开始,分数超过N时投掷次数的期望。

解题思路:设E[i]表示从i分开始,需要投掷几次才能超过N的期望,那么,就能推出递推式:E[i]=sum(E[i+k]*P[k])+E[0]*P[0]+1,就是E[i]到结束的次数应该是E[i+k]的次数加一,并且是考虑概率的。

上面的递推式分为两部分:与E[0]有关和与它无关,于是将E[i]构造成一个关于它的式子:E[i]=A[i]*E[0]+B[i]

然后带入原方程:E[i]=sum(A[i+k]*E[0]*P[k]+B[i]*P[k])+E[0]*P[0]+1=(sum(A[i+k]*P[k])+P[0])*E[0]+sum(B[i]*P[k])+1

所以A[i]=sum(A[i+k]*P[k])+P[0]    B[i]=sum(B[i]*P[k])+1

得到这个式子之后就可以用O(N*K)的递推求出A[0]和B[0]了。在带回到构造出的方程中:E[0]=A[0]*E[0]+B[0],变形后就得到结果了。


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;
const int MAX=100009;

double p[20];
double x[1009],y[1009];
int n,k1,k2,k3,a,b,c;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(x,0,sizeof x);
        memset(y,0,sizeof y);
        memset(p,0,sizeof p);
        scanf("%d %d %d %d %d %d %d",&n,&k1,&k2,&k3,&a,&b,&c);
        double k=1.0/k1/k2/k3;
        for(int i=1; i<=k1; i++)
            for(int j=1; j<=k2; j++)
                for(int q=1; q<=k3; q++)
                    if(i!=a||j!=b||q!=c)
                        p[i+j+q]+=k;
        for(int i=n; i>=0; i--)
        {
            x[i]=k;y[i]=1;
            for(int j=1; j<=k1+k2+k3; j++)
            {
                x[i]+=p[j]*x[i+j];
                y[i]+=p[j]*y[i+j];
            }
        }
        printf("%.16lf\n",y[0]/(1-x[0]));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值